Messaggio
  • EU e-Privacy Directive

    This website uses cookies to manage authentication, navigation, and other functions. By using our website, you agree that we can place these types of cookies on your device.

    View e-Privacy Directive Documents

LGL Login



Segui LGL su Twitter

LGL su Facebook



Utenti online

Cerca nel sito

Il Sondaggione!!

Libri "one shot", collane composte da più volumi, raccolte di racconti brevi. Quali sono le vostre opere interattive preferite?

JoomlaStats Visitor Details

Unknown Unknown
Unknown Unknown

Your IP: 54.236.35.159

Problema con Graphviz

Problema con Graphviz

Salve a tutti! Volevo provare la funzione che crea il grafo del LG tramite Graphviz, quindi ho scaricato e installato Graphviz dal sito ufficiale. Poi aprendo LC e cliccando su esporta file da Graphviz mi esce il messaggio di errore "imposta collegamento con graphviz". Ho letto su questo forum che per risolvere il problema bisogna far partire il file GVUI.EXE presente nella cartella di installazione di Graphviz, solo che nella mia non c'è nessun file con questo nome! Qualcuno è disponibile ad aiutare un ignorantone come il sottoscritto? Grazie.

firebead_elvenhair
Ultimo Vero Eroe
Barone del Sole
ranks
useravatar
Offline
2699 Messaggi
Info utenti nei messaggi
Administrator has disabled public posting

Re: Problema con Graphviz

Io mi ricordo che a suo tempo ho fatto un sacco di fatica ad impostare graphviz correttamente.... ma non mi ricordo piu' come ho fatto...

Un' idea, un concetto, un' idea, finche' resta un' idea e' soltanto un' astrazione.
Se potessi mangiare un' idea avrei fatto la mia rivoluzione.

Yaztromo
re fuso
Barone del Sole
ranks
useravatar
Offline
4444 Messaggi
Info utenti nei messaggi
Administrator has disabled public posting

Re: Problema con Graphviz

Aspetta che lo riscarico e vedo di combinare.. la prima volta non m'è riuscito

To serve and correct

Mancolista/Doppiolista

gabrieleud
Lo scopavirgole
Principe del Sole
ranks
useravatar
Offline
6381 Messaggi
Info utenti nei messaggi
Administrator has disabled public posting

Re: Problema con Graphviz

gabrieleud ha scritto:

Aspetta che lo riscarico e vedo di combinare.. la prima volta non m'è riuscito

Incrocio le dita...

firebead_elvenhair
Ultimo Vero Eroe
Barone del Sole
ranks
useravatar
Offline
2699 Messaggi
Info utenti nei messaggi
Administrator has disabled public posting

Re: Problema con Graphviz

Ciao, da buon informatico rispondo... smile

1) Ho scaricato la versione di LGC 2.0.3 (lo zip) e scompattato
2) Ho scaricato la versione di Graphviz 2.3.8 (lo zip) e scompattato
3) In LGC da file - preferenze , in "posizione del file dot.exe di Graphviz" ho sfogliato le cartelle fino a trovare il dot.exe nella cartella di graphviz sotto bin.
4) Confermato il percorso mi ha dato l'errore: "Failed to set data for 'Content Type'".
5) Fatto alcune prove ma alla fine rieseguendo LGC come amministratore (sotto windows 8 e immagino lo stesso sotto windows 7) è andato avanti senza problemi.

Hai windows 7/8? Perché allora il problema potrebbe essere stato quello di doverlo eseguire come amministratore.

Filippo
Iniziato
ranks
useravatar
Offline
72 Messaggi
Info utenti nei messaggi
Administrator has disabled public posting

Re: Problema con Graphviz

Grazie Filippo, ecco perché non riuscivo!

To serve and correct

Mancolista/Doppiolista

gabrieleud
Lo scopavirgole
Principe del Sole
ranks
useravatar
Offline
6381 Messaggi
Info utenti nei messaggi
Administrator has disabled public posting

Re: Problema con Graphviz

Grazie mille! Ora lo ho configurato correttamente, ma ho un altro problema che non mi spiego... apro lgccreator come amministratore, clicco su "esporta file graphviz, mi da il messaggio  esportazione completata su "NOMEDELLIBROGAME.JPG", ma quando vado nella cartella indicata al posto di un .jpg trovo un .dot... come lo apro?

firebead_elvenhair
Ultimo Vero Eroe
Barone del Sole
ranks
useravatar
Offline
2699 Messaggi
Info utenti nei messaggi
Administrator has disabled public posting

Re: Problema con Graphviz

Se non ricordo male il .dot è il formato di graphviz, prova ad aprirlo con gvedit (nella cartella \bin di graphviz).

Filippo
Iniziato
ranks
useravatar
Offline
72 Messaggi
Info utenti nei messaggi
Administrator has disabled public posting

Re: Problema con Graphviz

Perfetto, adesso riesco ad aprirlo: si apre però un menu con svariate opzioni, in cui non riesco a capire quale è quella per creare un grafo... (Scusate ragazzi, vi giuro che di solito non sono così inganfito!)

firebead_elvenhair
Ultimo Vero Eroe
Barone del Sole
ranks
useravatar
Offline
2699 Messaggi
Info utenti nei messaggi
Administrator has disabled public posting

Re: Problema con Graphviz

Una volta aperto il file vai in Graph e scegli Layout (oppure schiaccia F5) e ti crea il grafo.

Filippo
Iniziato
ranks
useravatar
Offline
72 Messaggi
Info utenti nei messaggi
Administrator has disabled public posting

Info Forum

Statistiche Forum:
 
Totale Discussioni:
5104
Totale Sondaggi:
98
Totale Messaggi:
145324
Totale Messaggi Oggi:
12
Info Utenti:
 
Totale Utenti:
6753
Ultimo Utente Registrato:
davidepezzi